Mengatasi validasi required html5 di safari


Pagi ini baru ngeh karena biasanya untuk form karena males buat form validasi biasanya cuman nambahin required di tag html5 untuk memeriksa input kosong, eh pagi ini pas ngetes di safari browser bawaan mac ternyata tag required ngga jalan di safari kalau ngga percaya silahkan dicoba pasti bablas he3.

Setelah browsing browsing ternyata benar required html5 ngga jalan di safari, tapi jangan sedih  saya sudah nemuin caranya yaitu nambahin plugin polyfiller.js dan nambahin sedikit javascript maka validasinya bisa jalan kembali

Caranya seperti ini cekidot this code …

Tambahkan link ini 

https://cdnjs.cloudflare.com/ajax/libs/webshim/1.16.0/dev/polyfiller.js 
Lalu buat script seperti ini 

  
        webshim.activeLang('en');
        webshims.polyfill('forms');
        webshims.cfg.no$Switch = true;
    

Lalu di htmlnya jangan lupa tambahin required

     <input type="text" class="form-control" name="title" placeholder="Judul Artikel" required>

Dah gitu aja gampangkan silahkan coba buka lagi form webnya di safari pasti ngga akan mau disubmit apabila kosong form inputnya :D.

Silahkan dicoba, apabila kamu tidak menggunakan safari di webmu tambahan ini tidak diperlukan karena secara native chrome dan firefox sudah support required tag, kalau di internet explorer (masih ada yang pake???) ngga tau dah :D.

Advertisements

2 thoughts on “Mengatasi validasi required html5 di safari

Ditunggu komennya ...

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s